Company data is not in sync when connected over a network
Description

Transactions or records processed on one computer might not appear on other computers logged into the same company. Check your connection and resolve syncing issues by following these steps.

Check if you're using Remote Data Access (RDA) rather than a network before you start.

Cause

There's an issue with either your local network connection, or each computer isn't pointing to the same set of data.

Resolution

Check the network connection

When computers connect over a network

To check if your computers connect:

  1. Log in to your company, click Help, then About.
  2. In the program Details section, note the Data Directory path. Do this on each computer you're checking the connection on.

To sync, both computers must point to the same data location.

This could be either:

 


When computers don't connect over the network

If both data paths begin with C:, each computer holds it's data locally. 

EXAMPLE: C:\ProgramData\Sage\Accounts\2024\Company.000\ACCDATA

Alternatively, they may point to different locations on different servers or computers.

In both scenarios, redirect your data directory to point to each other or to your server or another computer.

Before redirecting data paths, perform the checks in the Check for transactions processed during sync issues section.


Check for transactions processed during sync issues

  1. If you've processed while both computers have pointed to different datasets, check when the last time the data matched. Each computer may have transactions that don't appear on the other.

    EXAMPLE:  The last transaction that matches is number 201, but all later transactions differ on each computer.

  2. Back up your data on each computer.
  3. Decide which computer has the most recent data and needs the least re-processing.
  4. Restore that backup on the main computer that holds your data.

 TIP: When you restore a backup of your data to a different location or computer and use connected services, you'll see a Manage cloud connection window in v30.1 and above.  

  1. Depending on the number of transactions to reprocess, your options data on the main dataset are:
  • Manual re-process
  • Export missing transactions from the dataset, then import them into your chosen main dataset 

NOTE: If records, for example customers or suppliers, exist on the other backup but not this one, import these first before importing the missing transactions.

Once you've reprocessed, and your data is up to date where your data is held, redirect your other computers to point to this dataset. Follow the instructions on our Share and point to Sage Accounts data over a network article.

 

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