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Error: "Unable to send all emails","Generic COM Error" or "Failed to output..." when trying to send emails

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Summary

This guide explains how to resolve certain error messages you may see when emailing documents using Microsoft Outlook with Sage 50cloud Accounts or Sage 50cloud Payroll.

Description

IMPORTANT: If you experience the error 'Unable to send all emails...Unable to connect to the remote server' when emailing documents, this is due to a recent change Microsoft have made to the name of their live.co.uk email server. You can resolve this by updating your email settings in Sage 50cloud Accounts. Read more >

If you use Microsoft Outlook, when you try to email documents from Sage 50cloud Accounts or Sage 50cloud Payroll, one of the following message may appear:

'Unable to send all emails.'
'ExtendedErrorCode.COMError: "Generic COM Error'
'Failed to output to email'
'Error with the address Unknown Error. Please check Windows Event Log for more details.'

 NOTE: If you use Gmail or Yahoo, please follow these steps instead - Read more >

Cause

The following 'Unable to send all emails' errors can be due to different levels of user access for Sage 50cloud Accounts and Microsoft Outlook:

  • 'Unable to communicate with Microsoft Outlook as you are running Sage 50cloud Accounts as a Windows administrator and running Outlook as a user with a lower level of access.' Read more >
  • 'A problem occurred when sending your email. Please restart your computer and retry. If the problem persists, you may need to reinstall your Sage software and Microsoft Office.' Read more >

The following error may appear when using Microsoft Outlook 2013/2016 with Sage 50cloud Accounts v28:

  • 'Unable to send all emails. Error with the address xxx: Unknown Error. Please check Windows Event Log for more details.' Read more >

Other errors can be due to environmental settings or specific issues with the report you're running. Don't worry, in most cases you can resolve the issue by following all of the steps below.

Resolution

Before you start you must:

Restart your computer.

Check you're using a compatible version of Microsoft Office.

Check you've installed all required updates for Sage 50cloud Accounts or Sage 50cloud Payroll.

If you're not using Microsoft Outlook, check your SMTP settings and webmail password are correct.

If you're having issues with a customised layout, try a standard layout. If a standard layout emails succesfuly, try editing the standard layout and recreate your changes.

In your software, click Help, then click About. Under System Details in the column on the right, scroll down and check the status of Microsoft Office. If this shows n/a, first try an Office Online Repair. If this doesn't resolve the issue, you must uninstall Office and then your Sage software, then reinstall them in the same order to establish a connection between the software.

If the problem persists try the following steps below:

Does the issue occur in Sage 50 Accounts or Sage 50cloud Payroll?

Sage 50 Accounts Sage 50cloud Payroll


Still having an issue?

If you've completed all steps in the above wizard for your required product and still have an issue, we recommend you submit details about your issue so we can investigate it further.  Find out how >


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