Error: 'SBD Desktop has encountered an error and will now close'
Description

On opening any records in the software the following message appears and the software closes:

'SBD Desktop has encountered an error and will now close'

The problem can occur in both live data and Demo Data.

Cause

This issue can occur when you need to refresh some Sage accounts files. It can also occur if you use Bitdefender Total Security 2015 or Security Defender antivirus software.

Resolution

Follow each section if the issue persists when you open your records.

▼ Run as administrator
  • Right-click the Sage shortcut on your desktop and click Run as administrator

▼ Log in with a different username

Try logging into your company data with a different username.  For example, the Manager log in.

If this resolves the issue, either set up a new user, or delete the corrupt criteria files of the affected user.  


▼ Rename the SAGE.INI file
  1. On your keyboard, press the Windows key  + E.
  2. Browse to the following location: C:\ProgramData\Sage\Accounts
  3. Locate and right-click the SAGE.INI file.
  4. Rename the file as SAGE.OLD
  5. Open the software again.

▼ Rename the sage.usr file

Only rename this file if you have your serial number, activation key and account number to hand. 

  1. On your keyboard, press the Windows key  + E.
  2. Browse to: C:\ProgramData\Sage\Accounts\20xx

    Replace 20xx with the relevant year for your version.

  3. Right-click the sage.usr file and rename it sage.old
  4. Open the software again.

▼ Rename the licence files

These files are only present if you've opened the software on the computer.

  1. Close Sage Accounts.
  2. Rename the folder C:\Program Data\Sage\SDK Licence to C:\Program Data\Sage\SDK Licence OLD
  3. Browse to C:\Program Data\Sage\Accounts\<> and delete the sage.usr file.

It can also be necessary to remove the account number from the registry:

NOTE: Proceed with caution when editing the registry. If you require further help, contact your IT administrator. 

  1. Hold down the Windows key and press R, then type regedit and click OK.
  2. In the left-hand pane, browse to HKEY_CURRENT_USER\Software\Sage\Line 50 and double-click AccountNumber and delete the contents and click OK.
  3. Click File then click Exit.
  4. Open the software again.

▼ To prevent the problem from reoccurring in Bitdefender

If you get the same message when using other antivirus or malware software, apply the same exclusions listed below.

  1. Open Bitdefender.

    Bitdefender appears on the task bar as a white 'B' on a red background.
  2. Click Protection then Antivirus.
  3. Click Exclusions then Excluded processes.
  4. Click Add.
  5. Browse to the following file:
    v29 or above 32-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files\Sage\AccountsServiceVxx\sg50svc.exe
    • C:\Program Files\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    64-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\sg50svc.exe
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    v28 and v27 32-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files\Sage\AccountsServiceVxx\sg50svc_vxx.exe
    • C:\Program Files\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    64-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\sg50svc_vxx.exe
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    v26 32-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files\Sage\AccountsServiceV26\sg50svc_v26.exe
    • C:\Program Files\Sage\AccountsServiceV26\sg50CtrlSvc_v26.exe
    64-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files (x86)\Sage\AccountsServiceV26\sg50svc_v26.exe
    • C:\Program Files (x86)\Sage\AccountsServiceV26\sg50CtrlSvc_v26.exe
  6. Click Exclude Program.

If the issue persists, temporarily disable the Active Threat Control in Active Settings. For any further help if this resolves your issue, contact your IT support.


▼ To prevent the problem from reoccurring in Security Defender
  1. Open Security Defender.
  2. Add the following files to the list of exclusions:
    v29 or above 32-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files\Sage\AccountsServiceVxx\sg50svc.exe
    • C:\Program Files\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    64-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\sg50svc.exe
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    v28 and v27 32-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files\Sage\AccountsServiceVxx\sg50svc_vxx.exe
    • C:\Program Files\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    64-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\sg50svc_vxx.exe
    • C:\Program Files (x86)\Sage\AccountsServiceVxx\Sage.UK.Accounts50.Data.Service.Control_vxx.exe
    v26 32-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files\Sage\AccountsServiceV26\sg50svc_v26.exe
    • C:\Program Files\Sage\AccountsServiceV26\sg50CtrlSvc_v26.exe
    64-bit
    • [Sage Accounts program directory]\SBDDesktop.exe

      You can check the program directory in Sage Accounts in Help, About.
    • C:\Program Files (x86)\Sage\AccountsServiceV26\sg50svc_v26.exe
    • C:\Program Files (x86)\Sage\AccountsServiceV26\sg50CtrlSvc_v26.exe

▼ If the problem persists

There can be an issue with your software installation. To resolve this, completely remove and reinstall Sage Accounts.


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