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ERROR: Intermittent error "Connection to server failed" across all functions

Created on  | Last modified on 

Description

All users are seeing intermittent error "Connection to server failed : X3 engine error: <<masked>>/.users : :Application Non-existent!(2)"  This can be on the home page after logging in, adding attachments within a function, or when launching any classic function.   They also see this error in Accounting Tasks log files.  This error is intermittent but happens frequently.

There have not been any significant updates or changes to the X3 instance, however the servers were restarted due to a SQL Server update just before the issues began.

We can see in the Syracuse log files the issue seems random through out the day.  There are plenty of user sessions and batch jobs that can connect OK but some which fail, for example:

x3Com.runtime | error | connectToRuntime [x3Client x3Pid=undefined connecting sessionPool ] Connection to server failed : X3 engine error: <<masked>>/.users : :Application Non-existent!(2)

Cause

It was discovered that a folder had been deleted from SQL Server, the file system and in Folders function (GESADS) but was still listed in Endpoints and also had a SOAP pool configured and set to autostart.

Resolution

  1. Remove the SoapPool and EndPoint for the deleted folder
  2. Restart Syracuse