Skip to content
logo Knowledgebase

POH SOAP request errors when adding a new line to existing PO due to Popup window

Created on  | Last modified on 

Description

When adding an additional line onto an existing Purchase Order via SOAP Web Service call, if one of the original purchase order lines is closed, then the Web Service fails due to detecting a popup screen.   Error message is “X3 server is not allowed to ask the web service server to open a window

However, when you enter a new line via manual order entry, you do not see the popup when you enter a new line.  You only see a popup error screen if you physically click the line that is closed

The assertion is that SOAP Web Service behaviour is incorrect, as it does not replicate the behaviour of manual data entry.

Cause

When using the "modify" SOAP method this touches all the purchase order lines, which is why the error is popping up.  The "modify" method is the only option available here as "Insert line" is not implemented.

Resolution

There is no standard way to achieve this requirement.   POH has never been a "supported" object for the purposes of SOAP Web Services and therefore may need customisation to work per specific customer requirements.

The options are to:

- Consider a Customisation using SOAP request
- Use GraphQL technology rather than SOAP calls (X3 Builder). This is the technology that Sage are rapidly expanding and so is the future strategy.