Skip to content
logo Knowledgebase

ERROR: "Notification server 'SMTP_SAGE' could not be found" when running Data snapshot for outbound eInvoicing

Created on  | Last modified on 

Description

When processing outbound E-invoicing invoice (Customer einvoice generation) at the Data snapshot stage, I receive error message "Notification server 'SMTP_SAGE' could not be found."

Cause

XML mapping rules have not been updated correctly to point to your notification server

Resolution

The XML mapping rules need to be updated in Declarations, E-invoicing, Parameters, XML mapping rules (GESEINVMAP)

Check the mapping code you are using (for example UBL21G for GER legislation) then you will see the hard coded value SMTP_SAGE in the "E-mail address" section.

You can also see this data in SQL using the SQL below (Modify SEED for your folder name):

select MAPNAME_0, PARCOD_0, PARDES_0, PARVAL_0 FROM SEED.EINVMAP


These XML mapping rules can be changed, but the default mapping rules are not editable as they are owned by SAGE. The solution would be to copy the UBL21G seeded code and edit to your specific business needs. You at least need to modify the SMTP parameter value as required for your installation.  It validates the notification server value you enter is valid so ensure this is set correctly.