Summary
Description
Upon testing the Email settings within System Administration you may get an error.
Cause
This could be because your email provider via SMTP no longer supports Basic Authentication or App Passwords with Basic authentication. The function for Purchase Order Authorisation email uses Basic Authentication with SMTP to send emails.
Microsoft and Google plan to remove support for Basic Authentication on the dates shown below, this could have a knock on effect to Sage's SMTP emailing. You may no longer be able to send Purchase Order Authorisation emails if your email is hosted with Gmail or Outlook.com.
Microsoft plan to change this from 16 September 2024. Visit the Microsoft support guide if you'd like to find out more.
Google plan to apply their change from 30 September 2024. You can read more on Google's support guide.
NOTE: This is not to get mixed up with the Outlook application that may be installed on your machine. This guide is purely about Purchase Order Notification emails.
Resolution
Outlook.com
If your email is hosted with Outlook.com then there is no current workaround available. You will need to move to a provider that still supports Basic Authentication or App Passwords with Basic Authentication.
Gmail
You will need to setup a feature called App Password on Gmail. More information on how to do this can be found here.
Next all you need to do is update the details in System Administration > Messaging > E-mail settings. Replace the existing password with the new App Password. If you want to set up this feature in Sage for the first time then more information can be found here.
TIP: To test the email server settings, enter an email address in the Send E-Mail To box, then click Send. A test email message is sent to the address specified.
NOTE: If you are unable to move to another provider then you will need to skip the email notification step and navigate to the Purchase Order Authorisation or the Purchase Order Notifications workspace in the Desktop or the Self Service web app.
CAUTION: For security purposes do not use the same App Password with any other application. Only use it on Sage. If another application requires an App Password then Gmail accommodate this by allowing you to create multiple App Passwords.
CAUTION: Do not use this App Password to login to Gmail, doing so could cause your email provider to invalidate the App Password and result in emails from Sage 200 Professional to stop functioning.
NOTE: Sage will continue to investigate alternative options around this functionality.