User sessions randomly "hanging" for 3 to 30 minutes

Description

Users are randomly not able to work within X3. Whatever function they are in, they will get a blue progress circle but it will then hang for anything from 3 to 30 mins. Examples of effected functions are Account Balances (CONSNAT) and Purchase request (GESPSH). This is happening for multiple users, at random times on most days.

We used the Investigation Scripts to gather data until the issue occured. In the output files we were able to quickly see there was a database session holding a database lock, which was causing the other sessions to wait for the lock to be released.

For example, with one occurence we could see that:

- Database session 96 is UserA who's running GESBIS
This session is blocking session 78
Sage X3 session locks shows session 96 holding symbol NUMIMP
Can also see the last update for the session and has not been updated for 10 minutes (which correlates to when the users reported this occurence)

- Database session 78 is UserB who's running GIMPOBJ
This session is blocking session 52 and 83

- Database session 52 is UserC who's running REMBAN
- Database session 83 is UserD who's running SAIWRKPLN

Cause

Workflow Rules had "Debug" flag enabled. Whilst the user had the workflow debug log open on their screen, then the database lock was present and blocked the other users from progressing.

Resolution

After turning off the "Debug" in the workflow rules and the problem no longer occured.

Related Solutions

If you have access to SQL, you can quickly check your folder for Workflow Rules that have debug enabled using the following SQL:

select CODE_0, ENAFLG_0, DEBUG_0
from SEED.AWRKPAR
where DEBUG_0 = 2
order by ENAFLG_0

where SEED is the folder name.  

This SQL shows enabled and disabled workflow rules, but only enabled (where ENAFLG_0 has value = 2) should be impacting for this issue.

Solution Properties

Solution ID
230803141954680
Last Modified Date
Fri Mar 01 14:20:35 UTC 2024
Views
0