HTG - How to properly setup workflow email validation links to work

Summary

When setting the worklfows for Sales Order and Purchase orders, the system generates two links sent on an e-mail so the Signing User can Approve or Reject the Sales order and/or Purchase Order. This will allow the user ( the Signing User) to not necessary to log on into the X3 system. How do I set up PO signatures? How do I set up Purchase Order signature emails?

Description

If you've set an SSL / HTTPS external website as the entry point to X3, the parameters need to have its address as the server.

(This solution is for v7+)

Examples:

Parameter Description Value
AWRKSYRA Syracuse server https://MyExternalserver.com/trans/x3/erp/[foldername]
WRKRMTDIR Workflow links directory
WRKRMTHTTP Workflow links HTTP address MyExternalserver.com:443/sdata/x3/erp/[foldername]/$service
WRKRMTMAC Serverworkstaton workflow II
WRKSINTER Internet workflow feedback MyExternalserver.com:443/
WRKSINTRA Intranet workflow feedback MyExternalserver.com:443/

Cause

The links will usually not work if the workflow(s) is not set up properly.

Resolution

WARNING: The link which is generated is based upon the link used by the user signing into X3. For example: If Andy logs in via http://localhost:8124, this will be part of the signature link. Localhost is not resolvable outside the domain.

In order to configure the workflow properly, use the following steps:

1. Make sure that the X3 Web Services are installed on the SAFE X3 management Console.

  1. Log on your Sage X3 Server.
  2. Open the SAFE X3 System Management Console.
  3. Select the WEB Servers option
  4. Check if there is a Web Server configured.
  5. Take note of the Port used to connect to the Web Server. This will be used in the configuration steps below.

2 Enter the proper parameters on your Production and/or Test Folder

  1. Go to Setup, General parameters, Parameter values.
  2. Double-click SUP Supervisor to expand it.
  3. Select the SUPERVISOR chapter, FOLDER, <>.
  4. Select the Group WRK, the right click and select DETAIL.
  5. On the parameter values window, enter the following information ( remember that the names has to coincide with the server settings on the X3 Console)
    1. Parameter SERMES : enter your e-mail server name or IP address
      • If you don't user an e-mail server, enter RELAY.MAILINTERNAL.COM
    2. Parameter WRKRMTDIR: [install drive]:\Sage\[SolutionName]\FOLDER\[foldername]
      • Example: E:\SAGE\SAGEX3V7\FOLDERS\SEED
    3. Parameter WRKRMTHTTP: <>:<>/sdata/x3/erp/<>/$service
      • For example: localhost:8124/sdata/x3/erp/<>/$service
    4. Parameter WRKRMTMAC : <>:<>
      • Legacy parameter. Leave blank in v7 and above
      • For example: Same server name as above (not including http://) and the port shown in X3 Solution's Main Processor section.
    5. Parameter WRKSINTER : <>:<>
      • For example: Same server name and port as above (not including http://). Note: This IP address must be able to be "seen" externally from your domain.
    6. Parameter WRKSINTRA : <>:<>
      • For example: Same server name and port as above (not including http://).
  6. Click OK to close the page.
  7. Click SAVE to save the changes.

Solution Properties

Solution ID
224924350056835
Last Modified Date
Fri Jul 02 17:24:06 UTC 2021
Attributes
Product Details
Version: 7
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