Summary
You may encounter Unable to run report messages when trying to generate reports through Business Intelligence.
Description
You may encounter Unable to run report messages when trying to generate reports through Business Intelligence.
On top of this, the Sage BI add-in may be missing from the Excel ribbon and, if you try to reselect the Sage BI add-ins through Manage COM Add-ins in Excel, the selection is not retained.
Cause
This problem can occur when the COM Add-ins for Sage BI are disabled, but when enabling them through Microsoft Excel, the setting is not retained.
Resolution
Try the following steps to resolve this problem:
- Open the Registry Editor and navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins
- Highlight IAReportLib.Report and, in the right-hand pane, right-click and choose Modify on the LoadBehavior entry.
- In the Value data field, change the number to 3 then click OK.
- Carry out steps 2 and 3 again for IAXCalcVis.IACalcVis.
- Right-click on IAReportLib.Report in the left-hand pane and choose Permissions.
- On the Security window, add the affected user(s) and tick Full Control, then click OK.
- Carry out steps 5 and 6 again on IAXCalcVis.IACalcVis.
- Close the Registry Editor down and restart the PC.
If the registry entry reverts back to having a LoadBehavior of 2, after restarting the PC, further investigation will be required by the IT admin.