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Office 365 Onboarding Error - Something went wrong or No subscription found

Created on  | Last modified on 

Summary

When onboarding with Microsoft 365, you may see the error messages 'Authorise Delegated administration - Something Went wrong. Try again later. If this continues, contact support.' or 'Cannot setup your integration. We cannot setup your Sage 50c Accounts integration with Microsoft 365 because your Microsoft account does not include the required subscriptions.'

Cause

These messages can appear if you don't have the correct permissions on Microsoft 365, you're not using a supported version of Microsoft 365 or if you're a Microsoft CSP (Cloud Solution Provider).

If you're a CSP yourself, you will be prevented from signing our partner agreement, and therefore unable to use Sage 50 Accounts. This is due to the rules of the CSP partnership agreement that prevent a CSP partner providing online services to another CSP partner, official statement.

If you're not a CSP, follow the steps below.

 

Resolution

  1. Visit portal.office.com and sign in with the Microsoft 365 credentials being used to sync the data from Sage 50 Accounts to Microsoft 365.
  2. Click Admin then click Users and then Active Users.
  3. Click on the user that is signed in and check Global administrator is shown in Roles.
    • If it's not contact your Global administrator and discuss adding this role to your Microsoft 365 user.
  4. Check that one of the following products is shown in Product licences.
    • Microsoft 365 Business Premium
    • Microsoft 365 Business Standard
    • Microsoft 365 Business Basic
    • Microsoft 365 Enterprise E5
    • Microsoft 365 Enterprise E3
    • Microsoft 365 Enterprise E1
    • Microsoft 365 A1 for Faculty
    • Microsoft 365 A3 for Faculty
    • Microsoft 365 A5 for Faculty
    • Microsoft 365 A1 for Students
    • Microsoft 365 A3 for Students
    • Microsoft 365 A5 for Students
    • If it's not click Edit and assign one of the above licences.
  5. Click Close.

If the above steps confirm your settings are correct, or the issue persists after changing your settings, then follow the steps below to confirm you're using a supported version of Microsoft 365.

  1. Visit https://developer.microsoft.com/en-us/graph/graph-explorer
  2. Click Sign in with Microsoft, enter your Microsoft 365 credentials then review and grant the permissions for Microsoft Graph.
  3. Click modify permissions and check the following:
    • Directory.AccessAsUser.All
    • Directory.Read.All
    • Directory.ReadWrite.All
  4. Click Modify Permissions, then click sign out, close the web browser and wait 5 minutes for the permissions to be applied.
  5. Visits https://developer.microsoft.com/en-us/graph/graph-explorer
  6. Click Sign in with Microsoft and enter your Microsoft 365 credentials.
  7. Remove the text https://graph.microsoft.com/v1.0/me/ and replace with https://graph.microsoft.com/v1.0/subscribedSkus and then click Run Query.
  8. In the Response Preview look for skuId, there may be more than one if you have multiple licences on your Microsoft 365 tenant, your skuId must be the same as one of the following;
    • Microsoft 365 Business Premium         f245ecc8-75af-4f8e-b61f-27d8114de5f3 
    • Microsoft 365 Enterprise E1                 18181a46-0d4e-45cd-891e-60aabd171b4e
    • Microsoft 365 Enterprise E3                 6fd2c87f-b296-42f0-b197-1e91e994b900
    • Microsoft 365 Enterprise E5                 c7df2760-2c81-4ef7-b578-5b5392b571df
    • Microsoft 365 Business                    cbdc14ab-d96c-4c30-b9f4-6ada7cdc1d46     
    • Microsoft 365 A1 for faculty                   94763226-9b3c-4e75-a931-5c89701abe66
    • Microsoft 365 A3 for faculty                   e578b273-6db4-4691-bba0-8d691f4da603
    • Microsoft 365 A5 for faculty                   a4585165-0533-458a-97e3-c400570268c4
    • Microsoft 365 A1 for students                314c4481-f395-4525-be8b-2ec4bb1e9d91
    • Microsoft 365 A3 for students                98b6e773-24d4-4c0d-a968-6e787a1f8204
    • Microsoft 365 A5 for students                ee656612-49fa-43e5-b67e-cb1fdf7699df

  9. If your skuId isn't one of the above, your Microsoft 365 version isn't supported. To use the Sage 50 Microsoft 365 features, you need to move to a supported version of Microsoft 365.

After confirming your skuId, if you wish to revoke the permissions given to Microsoft Graph, please follow these steps:

  1. Visit https://portal.office.com/account/
  2. Sign in with the same Microsoft 365 user you used in Microsoft Graph.
  3. Click App Permissions.
  4. Click Revoke under Graph explorer.