Skip to content
logo Knowledgebase

HMRC E-filing rejection message 3304 original return already received.

Created on  | Last modified on 

Summary

What to do when you receive the 3304 rejection message.

Description

When submitting a return through Sage Corporation Tax, you may recieve the following rejection from HMRC:

Type: 3001 Business
Number: 3304
Location: Known facts check
Original return already received for this period.

Cause

This response is generated by HMRC's servers and indicates that an original return has already been received and accepted by them. This may not have been by your practice, or through Sage software, but HMRC have a submission record for this client.

Resolution

You'll need to submit once more but indicate that this is an amended return on the:

  • Online filing screen in Sage Corporation Tax.
  • Generate submission files screen in Sage Corporation Tax Online

If you believe you have not submitted an original return, we recommend contacting HMRC Online Help Desk on 0300 200 3600 and they will be able to confirm the original submission and acceptance or rejection.

 

Upgrading your licence

Need a little more room? To add extra companies, users, employees or more to your software licence, leave your details and we'll be in touch.

Leave your details

Image