Error: When printing "Unable to connect: incorrect log on parameters"
Description

After an in-place upgrade from V11 to V12 users can login to X3 and process normally, and most printouts work as expected. Certain customised reports are failing with error " Unable to connect : incorrect log on parameters " 

 The custom report has a subreport included within it, and you find that when you remove the subreport, then the custom report will print out with no error 

 To see the error : 
1. Navigate to Development> Script Dictionary> Reports 
2. Query back your custom report definition 
3. Click "Printout" button 
4. Select any destination, including Preview output types, then click "Print" button to generate the report 
5. The error message will appear and the report is not generated 

 The full error message will be similar to the following: 
 Job 2 - ERR 504 coming from the edition server : Error induced by the print engine Crystal .NET. 
BPCINVWAFAC.rpt - - Message 1/3 : Error running the report: D:\Sage\SafeX3\X3V12PRTSVR\Data\SEED_x3erpv12vm_50012\BRI\Report\BPCINVWAFAC_CrDll_SEED.rpt 
- Message 2/3 : Connection error: Table:BPCINVLIG - Location .SEED.BPCINVLIG 
- Message 3/3 : Error in File BPCINVWAFAC_CrDll_SEED 1288_5136_{D3C425DF-4DFF-40C4-A6A7-A277ABC970E0}.rpt: 
Unable to connect: incorrect log on parameters. 
Details: Database Vendor Code: 18456   

 You may also see a slightly different error such as below which could have the same underlying cause: 
 Failed to retrieve data from the database. Details: Database Vendor Code: 229

Cause

This issue is caused by either:

1. The adxodbc file located in the ...\Folders\<> directory being invalid, as this file holds the connection details

2. There is binary ORAPASSE.adx located in the child folder TRT directory

Resolution
[BCB:1:Backup warning:ECB]

1. Regenerate the AdxOdbc file

A. The recomended way to resolve the issue with AdxODBC file is to re-save the folder password in the X3 Console

NOTE: You do not need to change the password, but re-save the existing password

a. Ensure no users are connected to the folder concerned
b. Launch X3 Console
c. Connect to the solution
d. Click the "Folders" button
e. Select the appropriate folder in the right hand pane
f. Click the "Password" button
g. Enter the old password
h. Enter then re-confirm the new password. NOTE: this should be the same as the old password, unless you are following the full process to change a folder password
i. Click "Yes" to confirm the configuration
j. Once completed, you can exit X3 Console
k. Check your report printout works OK


B. As an alternative, if you cannot access the X3 console, you can recreate the adxodbc file from the command line using the following steps:

a. Ensure no users are connected to the folder concerned
b. Use SQL Server Managment Server to test the folder name and password work OK
c. Launch CMD prompt
d. cd to the ...\runtime\bin directory
e. Run command "env.bat" to setup environment variables
f. cd to child folder for example "D:\Sage\X3ERPV12\Folders\SEED"
g. Run the following command:
adxodbc -u <> -p <> -b <>** -d <>** <>
** This information can be found in the solution.xml file in ...\Folders\solutions.xml
SQLBASE = database.adonix.sqlbase
RUNTIME_NAME=component.runtime.name

For example
adxodbc -u SEED -p tiger -b x3erpv12 -d X3ERPV12 SEED


You can now confirm that the adxodbc file has been created in ...\Folders\<> and then re-test your report to confirm it now works as expected


2. If you have ORAPSSE.adx in the child folder TRT folder, this should be removed




Steps to duplicate
Related Solutions

Error:When printing "Unable to connect: incorrect log on parameters"