Error: 'The attachments folder cannot be found' when opening attachments
Description
Cause

After upgrading from Sage 50 Accounts v26 to v27 you may receive the following error when opening attachments:

The attachments folder

....\Transaction Attachments\Purchase Transactions cannot be found. The folder has been renamed for deleted, or data has been restored which did not include transaction attachments.

You are unable to view attachments immediately due to the directory looking in the wrong folder. This can be resolved by copying the Accdata, Memo and Vatrtns folders from the original data location.

You receive this error because the company file looking in the wrong location. You can resolve this by copying the Accdata, Memo and Vatrtns folders from the original data location, and updating the data path in the company file.

Resolution
Open the v26 and v27 data directories for your company
  1. Browse to the v26 data directory of your company.

    NOTE: This is the same Company Data location you used when connecting to the data.

  2. Open the v27 data directory, go to Help and click About under Program Details click on the Data Directory
  3. Select the Accdata, Memo and Vatrtns folders.
  4. Then right-click then click Copy.
  5. In the v26 data directory, right-click and Paste the files.
  6. When prompted click Replace the files in this destination.
Edit the v27 company file
  1. Click the Windows Key + E then browse to C:\PROGRAMDATA\SAGE\ACCOUNTS\2021.
  2. Right-click the Company file, click Open with then click Notepad.
  3. Edit the line relating to this company and change to be the v26 Data Directory.

    EXAMPLE: If your v26 data path is C:\PROGRAMDATA\SAGE\ACCOUNTS\2020\COMPANY.001 then enter that into the company file.

  4. Click Save and close the file.
  5. Close Sage 50 Accounts and re-open.


Steps to duplicate
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