'Error in record x: Account Reference: Bank account type is not valid for the transaction type' when importing into Sage Accounts
Description

When importing data into Sage Accounts, you may receive the following file import error:

Error in record x: Account Reference: Bank account type is not valid for the transaction type'

Cause

his message appears when you try to import a bank transaction where the transaction type is inconsistent with the bank account type. For example, trying to import a cash payment into a visa bank account.

To fix this error, either remove this line from the import file or amend the transaction type to be consistent with the bank account type then import the file again.

Resolution

To check the bank account type, on the navigation bar click Bank accounts, then:

  • Double-click the relevant bank account, then check the A/C Type.

The bank transactions to use for each bank type are as follows:

Cheque AccountBank Payment (BP)
Bank Receipt (BR)
Cash AccountCash Payment (CP)
Cash Receipt (CR)
Credit Card AccountVisa Payment (VP)
Visa Receipt (VR)



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